<!DOCTYPE html><html lang="en"><head><meta name="theme-color" content="#F0F0F0"/><link rel="manifest" href="/manifests/2.7.0/manifest.json"/><link rel="apple-touch-icon" href="/favicons/192x192.png"/><meta name="viewport" content="width=device-width,minimum-scale=1,initial-scale=1"/><meta charSet="utf-8"/><script>(function(w,d,s,l,i){w[l]=w[l]||[]; w[l].push({'gtm.start': new Date().getTime(),event:'gtm.js'}); var f=d.getElementsByTagName(s)[0], j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:''; j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl; f.parentNode.insertBefore(j,f); })(window,document,'script','dataLayer','GTM-KGVFCF9');</script><meta name="description" content="The IOTA Foundation said it has resolved a software bug that prevented transactions from confirming on the IOTA network for 15 hours. "/><link rel="alternate" type="application/rss+xml" title="CoinDesk RSS Feed" href="https://www.coindesk.com/feed"/><link rel="icon" href="/favicons/32x32.png"/><link rel="stylesheet" href="https://use.typekit.net/rfs5mhf.css"/><link rel="canonical" href="https://www.coindesk.com/iota-fixes-minor-network-bug-following-15-hour-mainnet-downtime"/><link rel="amphtml" href="https://www.coindesk.com/iota-fixes-minor-network-bug-following-15-hour-mainnet-downtime?amp=1"/><meta property="og:locale" content="en_US"/><meta property="og:type" content="article"/><meta property="og:title" content="IOTA Fixes &#x27;Minor&#x27; Network Bug Following 15-Hour Mainnet Downtime - CoinDesk"/><meta property="og:description" content="The IOTA Foundation said it has resolved a software bug that prevented transactions from confirming on the IOTA network for 15 hours."/><meta property="og:url" content="https://www.coindesk.com/iota-fixes-minor-network-bug-following-15-hour-mainnet-downtime"/><meta property="og:site_name" content="CoinDesk"/><meta property="article:tag" content="IOTA"/><meta property="article:tag" content="Bug"/><meta property="article:section" content="Tech"/><meta property="article:published_time" content="2019-12-30T13:40:00+00:00"/><meta property="article:modified_time" content="2019-12-30T14:56:21+00:00"/><meta property="og:updated_time" content="2019-12-30T14:56:21+00:00"/><meta property="og:image" content="https://static.coindesk.com/wp-content/uploads/2018/08/norway.jpg"/><meta property="og:image:secure_url" content="https://static.coindesk.com/wp-content/uploads/2018/08/norway.jpg"/><meta property="og:image:width" content="1500"/><meta property="og:image:height" content="1000"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:description" content="The IOTA Foundation said it has resolved a software bug that prevented transactions from confirming on the IOTA network for 15 hours."/><meta name="twitter:title" content="IOTA Fixes &#x27;Minor&#x27; Network Bug Following 15-Hour Mainnet Downtime - CoinDesk"/><meta name="twitter:site" content="@coindesk"/><meta name="twitter:image" content="https://static.coindesk.com/wp-content/uploads/2018/08/norway.jpg"/><meta name="twitter:creator" content="@paddybaker_"/><meta name="twitter:account_id" content="1418565129"/><meta content="IOTA Fixes &#x27;Minor&#x27; Network Bug Following 15-Hour Mainnet Downtime - CoinDesk"/><meta name="keywords" content="IOTA, Bug"/><script type="application/ld+json">{"@context":"http://schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.coindesk.com/iota-fixes-minor-network-bug-following-15-hour-mainnet-downtime"},"headline":"IOTA Fixes 'Minor' Network Bug Following 15-Hour Mainnet Downtime - CoinDesk","url":"https://www.coindesk.com/iota-fixes-minor-network-bug-following-15-hour-mainnet-downtime","thumbnailUrl":"https://static.coindesk.com/wp-content/uploads/2018/08/norway.jpg","image":{"@type":"ImageObject","url":"https://static.coindesk.com/wp-content/uploads/2018/08/norway.jpg"},"dateCreated":"2019-12-30T13:40:00+00:00","datePublished":"2019-12-30T13:40:00+00:00","dateModified":"2019-12-30T14:56:21+00:00","articleSection":"Tech","author":["Paddy Baker"],"creator":["Paddy Baker"],"keywords":["IOTA","Bug"],"publisher":{"@type":"Organization","name":"CoinDesk","logo":{"@type":"ImageObject","url":"https://static.coindesk.com/images/facebook/default.51070683.png"}}}</script><meta name="parsely-metadata" content="{&quot;id&quot;:439788,&quot;excerpt&quot;:&quot;The IOTA Foundation said it has resolved a software bug that prevented transactions from confirming on the IOTA network for 15 hours. &quot;,&quot;path&quot;:&quot;/iota-fixes-minor-network-bug-following-15-hour-mainnet-downtime&quot;}"/><title>IOTA Fixes &#x27;Minor&#x27; Network Bug Following 15-Hour Mainnet Downtime - CoinDesk</title><script async="" src="https://platform.twitter.com/widgets.js"></script><meta name="next-head-count" content="38"/><link rel="preload" href="https://static.coindesk.com/2.7.0/pages/%5Bslug%5D.js" as="script" crossorigin="anonymous"/><link rel="preload" href="https://static.coindesk.com/2.7.0/pages/_app.js" as="script" crossorigin="anonymous"/><link rel="preload" href="https://static.coindesk.com/runtime/webpack-8fb5bf10fdd6e1b93d46.js" as="script" crossorigin="anonymous"/><link rel="preload" href="https://static.coindesk.com/chunks/commons.9bc87ee77954726641bc.js" as="script" crossorigin="anonymous"/><link rel="preload" href="https://static.coindesk.com/chunks/styles.093f8a110b0749276289.js" as="script" crossorigin="anonymous"/><link rel="preload" href="https://static.coindesk.com/runtime/main-dbdf3d4a43eea9f43f09.js" as="script" crossorigin="anonymous"/><link rel="preload" href="https://static.coindesk.com/chunks/commons.d7bf7a7d.chunk.css" as="style" crossorigin="anonymous"/><link rel="stylesheet" href="https://static.coindesk.com/chunks/commons.d7bf7a7d.chunk.css" crossorigin="anonymous"/><link rel="preload" href="https://static.coindesk.com/chunks/styles.5df9e5ee.chunk.css" as="style" crossorigin="anonymous"/><link rel="stylesheet" href="https://static.coindesk.com/chunks/styles.5df9e5ee.chunk.css" crossorigin="anonymous"/></head><body class="no-js"><script>document.body.classList.remove("no-js");</script><noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KGVFCF9" height="0" width="0" style="display:none;visibility:hidden"></iframe> <img src="https://www.facebook.com/tr?id=472218139648482&amp;ev=PageView&amp;noscript=1" height="1" width="1" style="display:none" alt="Facebook pixel"  /> <img src="https://analytics.twitter.com/i/adsct?txn_id=l4l2u&amp;p_id=Twitter&amp;tw_sale_amount=0&amp;tw_order_quantity=0" height="1" width="1" style="display:none;" alt="Twitter pixel"  /> <img src="https://certify.alexametrics.com/atrk.gif?account=7nk2s1hNdI20fn" height="1" width="1" style="display:none" alt="Alexa pixel" /></noscript><div id="__next"><section class="site-nav " role="navigation" aria-label="Main navigation"><header class="site-nav-desktop"><div class="site-nav-spacer"></div><div class="site-nav-spacer-pricing minimized"></div><div class="site-nav-wrapper"><nav class="navbar"><div class="container"><div class="nav-wrapper"><div class="logo-wrapper"><a class="coindesk-logo" href="/"><img src="https://static.coindesk.com/images/logo-5ce6d3185603319740c3c34bbf2ec628.svg" alt="CoinDesk Bitcoin News"/></a></div><div class="nav-items"><ul class="top-nav "><li class="top-nav-item 
                                   
                                  "><button>News</button><nav class="nav-expanded has-bg"><div class="container"><button class="button close-button"><img src="https://static.coindesk.com/images/close-icon-64f2495836d72706c350aea6c5bbe542.svg"/></button><div class="site-menu  two-columns"><div><section class="submenu has-focus"><ul class="submenu-list"><li class="submenu-item 
               
              
              "><a class="submenu-button" href="/news"><i class="bullet"></i>Latest</a></li><li class="submenu-item 
               
              
              "><a class="submenu-button" href="/opinion"><i class="bullet"></i>Opinion</a></li><li class="submenu-item 
               
              
              "><a class="submenu-button" href="/features"><i class="bullet"></i>Features</a></li><li class="submenu-item 
               
              
              "><a class="submenu-button" href="/video"><i class="bullet"></i>Video</a></li><li class="submenu-item 
               
              
              "><a class="submenu-button" href="/category/markets"><i class="bullet"></i>Markets</a></li><section class="newsletter-card decorated"><div class="decoration"></div><div class="desc-content"><h2 class="heading">Get the Latest from CoinDesk</h2><p>Sign up for our newsletter</p><div class="checkboxes"><div class="coindesk-checkbox"><div class="pretty p-svg p-smooth"><input type="checkbox" id="checkbox-bites-96703" checked="" name="bites"/><div class="state"><svg class="svg-icon svg svg-icon" width="20" height="20" x="0px" y="0px" viewBox="0 0 20 20"><path d="M5.25 9.486L14.543 0 16 1.428 5.307 12.343 0 7.34l1.4-1.484z"></path></svg><label for="checkbox-bites-96703"><span>Daily</span></label></div></div></div><div class="coindesk-checkbox"><div class="pretty p-svg p-smooth"><input type="checkbox" id="checkbox-markets-96703" checked="" name="markets"/><div class="state"><svg class="svg-icon svg svg-icon" width="20" height="20" x="0px" y="0px" viewBox="0 0 20 20"><path d="M5.25 9.486L14.543 0 16 1.428 5.307 12.343 0 7.34l1.4-1.484z"></path></svg><label for="checkbox-markets-96703"><span>Markets</span></label></div></div></div><div class="coindesk-checkbox"><div class="pretty p-svg p-smooth"><input type="checkbox" id="checkbox-institutional-96703" checked="" name="institutional"/><div class="state"><svg class="svg-icon svg svg-icon" width="20" height="20" x="0px" y="0px" viewBox="0 0 20 20"><path d="M5.25 9.486L14.543 0 16 1.428 5.307 12.343 0 7.34l1.4-1.484z"></path></svg><label for="checkbox-institutional-96703"><span>Institutional</span></label></div></div></div></div><p class="gdpr-copy">By signing up, you will receive emails about CoinDesk products and you agree to our<!-- --> <a href="/terms" target="_blank">terms &amp; conditions</a> <!-- -->and<!-- --> <a href="/privacy" target="_blank">privacy policy</a></p></div><div class="singup-input-controls input-content"><input type="email" placeholder="Enter your mail" value=""/><div class="buttons"><button disabled="" class="button primary-button primary-button-default disabled">Sign Up</button></div></div><div class="error-content ">Please enter a valid email address</div></section></ul><ul class="submenu-list"><li class="submenu-item 
               
              
              "><a class="submenu-button" href="/category/tech"><i class="bullet"></i>Tech</a></li><li class="submenu-item 
               
              
              "><a class="submenu-button" href="/category/business"><i class="bullet"></i>Business</a></li><li class="submenu-item 
               
              
              "><a class="submenu-button" href="/category/policy-regulation"><i class="bullet"></i>Policy &amp; Regulation</a></li><li class="submenu-item 
               
              
              "><a class="submenu-button" href="/category/people"><i class="bullet"></i>People</a></li><li class="submenu-item 
               
              
              "><button class="submenu-button"><i class="bullet"></i>Topics</button><ul class="links-list
                              list
                              "></ul></li></ul></section></div><div></div></div></div></nav></li><li class="top-nav-item 
                                   
                                  "><button>Learn</button><nav class="nav-expanded has-bg"><div class="container"><button class="button close-button"><img src="https://static.coindesk.com/images/close-icon-64f2495836d72706c350aea6c5bbe542.svg"/></button><div class="site-menu  false"><div><section class="submenu has-focus"><ul class="submenu-list"><li class="submenu-item 
               
              
              "><button class="submenu-button"><i class="bullet"></i>Bitcoin 101</button><ul class="links-list list-digits"><li><a class="links-item" href="/learn/bitcoin-101/what-is-bitcoin"><strong>01</strong>What is Bitcoin?</a></li><li><a class="links-item" href="/learn/bitcoin-101/how-can-i-buy-bitcoins"><strong>02</strong>How Can I Buy Bitcoin?</a></li><li><a class="links-item" href="/learn/bitcoin-101/how-to-store-your-bitcoins"><strong>03</strong>How to Store Your Bitcoin</a></li><li><a class="links-item" href="/learn/bitcoin-101/sell-bitcoin"><strong>04</strong>How to Sell Bitcoin</a></li><li><a class="links-item" href="/learn/bitcoin-101/how-do-bitcoin-transactions-work"><strong>05</strong>How do Bitcoin Transactions Work?</a></li><li><a class="links-item" href="/learn/bitcoin-101/how-bitcoin-mining-works"><strong>06</strong>How Bitcoin Mining Works</a></li><li><a class="links-item" href="/learn/bitcoin-101/can-bitcoin-scale"><strong>07</strong>Can Bitcoin Scale?</a></li><li><a class="links-item" href="/learn/bitcoin-101/what-is-the-lightning-network"><strong>08</strong>What is Bitcoin&#x27;s Lightning Network?</a></li><li><a class="links-item" href="/learn/bitcoin-101/get-started-mining-pools"><strong>09</strong>What are Bitcoin Mining Pools?</a></li><li><a class="links-item" href="/learn/bitcoin-101/what-can-you-buy-with-bitcoins"><strong>10</strong>What Can You Buy with Bitcoin?</a></li></ul><a class="sub-all-link" href="/learn/bitcoin-101">All Bitcoin 101 Guides<img src="https://static.coindesk.com/images/arrow-right-white-49f0e7830badb677568dfe5c47e008a5.svg"/></a></li><li class="submenu-item 
               
              
              "><button class="submenu-button"><i class="bullet"></i>Blockchain 101</button><ul class="links-list list-digits"><li><a class="links-item" href="/learn/blockchain-101/what-is-blockchain-technology"><strong>01</strong>What is Blockchain Technology?</a></li><li><a class="links-item" href="/learn/blockchain-101/how-does-blockchain-technology-work"><strong>02</strong>How Does Blockchain Technology Work?</a></li><li><a class="links-item" href="/learn/blockchain-101/what-can-a-blockchain-do"><strong>03</strong>What Can a Blockchain Do?</a></li><li><a class="links-item" href="/learn/blockchain-101/what-is-a-distributed-ledger"><strong>04</strong>What is a Distributed Ledger?</a></li><li><a class="links-item" href="/learn/blockchain-101/why-use-a-blockchain"><strong>05</strong>Why Use a Blockchain?</a></li><li><a class="links-item" href="/learn/blockchain-101/how-blockchain-technology-change-finance"><strong>06</strong>How Could Blockchain Technology Change Finance?</a></li></ul><a class="sub-all-link" href="/learn/blockchain-101">All Blockchain 101 Guides<img src="https://static.coindesk.com/images/arrow-right-white-49f0e7830badb677568dfe5c47e008a5.svg"/></a></li><li class="submenu-item 
               
              
              "><button class="submenu-button"><i class="bullet"></i>Ethereum 101</button><ul class="links-list list-digits"><li><a class="links-item" href="/learn/ethereum-101/what-is-ethereum"><strong>01</strong>What is Ethereum?</a></li><li><a class="links-item" href="/learn/ethereum-101/how-to-use-ethereum"><strong>02</strong>How to Use Ethereum</a></li><li><a class="links-item" href="/learn/ethereum-101/how-ethereum-works"><strong>03</strong>How Ethereum Works</a></li><li><a class="links-item" href="/learn/ethereum-101/what-is-a-decentralized-application-dapp"><strong>04</strong>What is a Decentralized Application?</a></li><li><a class="links-item" href="/learn/ethereum-101/ethereum-smart-contracts-work"><strong>05</strong>How Do Ethereum Smart Contracts Work?</a></li><li><a class="links-item" href="/learn/ethereum-101/ethereum-mining-works"><strong>06</strong>How Ethereum Mining Works</a></li><li><a class="links-item" href="/learn/ethereum-101/will-ethereum-scale"><strong>07</strong>How Will Ethereum Scale?</a></li><li><a class="links-item" href="/learn/ethereum-101/how-to-mine-ethereum"><strong>08</strong>How to Mine Ethereum</a></li><li><a class="links-item" href="/learn/ethereum-101/what-is-ether-ethereum-cryptocurrency"><strong>09</strong>What is Ether?</a></li><li><a class="links-item" href="/learn/ethereum-101/who-created-ethereum"><strong>10</strong>Who Created Ethereum?</a></li></ul><a class="sub-all-link" href="/learn/ethereum-101">All Ethereum 101 Guides<img src="https://static.coindesk.com/images/arrow-right-white-49f0e7830badb677568dfe5c47e008a5.svg"/></a></li><li class="submenu-item 
               
              
              "><button class="submenu-button"><i class="bullet"></i>Trading 101</button><ul class="links-list list-digits"><li><a class="links-item" href="/learn/trading-101/how-to-trade-crypto-on-binance"><strong>01</strong>How to Trade Crypto On Binance</a></li><li><a class="links-item" href="/learn/trading-101/how-to-trade-crypto-on-bitfinex"><strong>02</strong>How to Trade Crypto On Bitfinex</a></li><li><a class="links-item" href="/learn/trading-101/how-to-trade-crypto-on-bitmex"><strong>03</strong>How to Trade Crypto On BitMEX</a></li><li><a class="links-item" href="/learn/trading-101/how-to-trade-crypto-on-bitstamp"><strong>04</strong>How to Trade Crypto On Bitstamp</a></li><li><a class="links-item" href="/learn/trading-101/how-to-trade-crypto-on-bittrex"><strong>05</strong>How to Trade Crypto On Bittrex</a></li><li><a class="links-item" href="/learn/trading-101/how-to-trade-crypto-on-coinbase"><strong>06</strong>How to Trade Crypto On Coinbase</a></li><li><a class="links-item" href="/learn/trading-101/how-to-trade-crypto-on-gemini"><strong>07</strong>How to Trade Crypto On Gemini</a></li><li><a class="links-item" href="/learn/trading-101/how-to-trade-crypto-on-huobi"><strong>08</strong>How to Trade Crypto on Huobi</a></li><li><a class="links-item" href="/learn/trading-101/how-to-trade-crypto-on-kraken"><strong>09</strong>How to Trade Crypto On Kraken</a></li><li><a class="links-item" href="/learn/trading-101/how-to-trade-crypto-on-poloniex"><strong>10</strong>How to Trade Crypto On Poloniex</a></li><li><a class="links-item" href="/learn/trading-101/understanding-bitcoin-price-charts"><strong>11</strong>Understanding Bitcoin Price Charts</a></li></ul><a class="sub-all-link" href="/learn/trading-101">All Trading 101 Guides<img src="https://static.coindesk.com/images/arrow-right-white-49f0e7830badb677568dfe5c47e008a5.svg"/></a></li></ul><a class="all-link" href="/learn">All 101 Guides<img src="https://static.coindesk.com/images/arrow-right-white-49f0e7830badb677568dfe5c47e008a5.svg"/></a></section></div><div><section class="newsletter-card decorated"><div class="decoration"></div><div class="desc-content"><h2 class="heading">Get the Latest from CoinDesk</h2><p>Sign up for our newsletter</p><div class="checkboxes"><div class="coindesk-checkbox"><div class="pretty p-svg p-smooth"><input type="checkbox" id="checkbox-bites-96704" checked="" name="bites"/><div class="state"><svg class="svg-icon svg svg-icon" width="20" height="20" x="0px" y="0px" viewBox="0 0 20 20"><path d="M5.25 9.486L14.543 0 16 1.428 5.307 12.343 0 7.34l1.4-1.484z"></path></svg><label for="checkbox-bites-96704"><span>Daily</span></label></div></div></div><div class="coindesk-checkbox"><div class="pretty p-svg p-smooth"><input type="checkbox" id="checkbox-markets-96704" checked="" name="markets"/><div class="state"><svg class="svg-icon svg svg-icon" width="20" height="20" x="0px" y="0px" viewBox="0 0 20 20"><path d="M5.25 9.486L14.543 0 16 1.428 5.307 12.343 0 7.34l1.4-1.484z"></path></svg><label for="checkbox-markets-96704"><span>Markets</span></label></div></div></div><div class="coindesk-checkbox"><div class="pretty p-svg p-smooth"><input type="checkbox" id="checkbox-institutional-96704" checked="" name="institutional"/><div class="state"><svg class="svg-icon svg svg-icon" width="20" height="20" x="0px" y="0px" viewBox="0 0 20 20"><path d="M5.25 9.486L14.543 0 16 1.428 5.307 12.343 0 7.34l1.4-1.484z"></path></svg><label for="checkbox-institutional-96704"><span>Institutional</span></label></div></div></div></div><p class="gdpr-copy">By signing up, you will receive emails about CoinDesk products and you agree to our<!-- --> <a href="/terms" target="_blank">terms &amp; conditions</a> <!-- -->and<!-- --> <a href="/privacy" target="_blank">privacy policy</a></p></div><div class="singup-input-controls input-content"><input type="email" placeholder="Enter your mail" value=""/><div class="buttons"><button disabled="" class="button primary-button primary-button-default disabled">Sign Up</button></div></div><div class="error-content ">Please enter a valid email address</div></section></div></div></div></nav></li><li class="top-nav-item 
                                   
                                  "><button>Research</button><nav class="nav-expanded has-bg"><div class="container"><button class="button close-button"><img src="https://static.coindesk.com/images/close-icon-64f2495836d72706c350aea6c5bbe542.svg"/></button><div class="site-menu  false"><div><section class="submenu has-focus"><ul class="submenu-list"><li class="submenu-item 
               
              
              "><a class="submenu-button" href="/data"><i class="bullet"></i>Cryptoeconomics Data</a></li><li class="submenu-item 
               
              
              "><button class="submenu-button"><i class="bullet"></i>Research Reports</button><ul class="links-list
                              list
                              "><li><a class="links-item" href="/crypto-investment-research/crypto-in-context"><div class="list">Crypto in Context</div></a></li><li><a class="links-item" href="/crypto-investment-research/crypto-derivatives"><div class="list">Crypto Derivatives</div></a></li><li><a class="links-item" href="/crypto-investment-research/crypto-custody"><div class="list">Crypto Custody</div></a></li><li><a class="links-item" href="/crypto-investment-research/crypto-fundamentals"><div class="list">Crypto Fundamentals</div></a></li><li><a class="links-item" href="/crypto-investment-research/is-bitcoin-a-safe-haven"><div class="list">Is Bitcoin a Safe Haven?</div></a></li></ul><a class="sub-all-link" href="/crypto-investment-research">See all<img src="https://static.coindesk.com/images/arrow-right-white-49f0e7830badb677568dfe5c47e008a5.svg"/></a></li><li class="submenu-item 
               
              
              "><a class="submenu-button" href="/research-archive"><i class="bullet"></i>Research Archive</a></li><li class="submenu-item 
               
              
              "><button class="submenu-button"><i class="bullet"></i>Resources</button><ul class="links-list
                              list
                              "><li><a class="links-item" href="/calculator"><div class="list">Bitcoin Calculator</div></a></li><li><a class="links-item" href="/ico-calendar"><div class="list">ICO Calendar</div></a></li><li><a class="links-item" href="/bitcoin-events"><div class="list">Industry Events Calendar</div></a></li><li><a class="links-item" href="/coindesk-api"><div class="list">CoinDesk API</div></a></li></ul></li></ul></section></div><div><section class="newsletter-card decorated"><div class="decoration"></div><div class="desc-content"><h2 class="heading">Get the Latest from CoinDesk</h2><p>Sign up for our newsletter</p><div class="checkboxes"><div class="coindesk-checkbox"><div class="pretty p-svg p-smooth"><input type="checkbox" id="checkbox-bites-96705" checked="" name="bites"/><div class="state"><svg class="svg-icon svg svg-icon" width="20" height="20" x="0px" y="0px" viewBox="0 0 20 20"><path d="M5.25 9.486L14.543 0 16 1.428 5.307 12.343 0 7.34l1.4-1.484z"></path></svg><label for="checkbox-bites-96705"><span>Daily</span></label></div></div></div><div class="coindesk-checkbox"><div class="pretty p-svg p-smooth"><input type="checkbox" id="checkbox-markets-96705" checked="" name="markets"/><div class="state"><svg class="svg-icon svg svg-icon" width="20" height="20" x="0px" y="0px" viewBox="0 0 20 20"><path d="M5.25 9.486L14.543 0 16 1.428 5.307 12.343 0 7.34l1.4-1.484z"></path></svg><label for="checkbox-markets-96705"><span>Markets</span></label></div></div></div><div class="coindesk-checkbox"><div class="pretty p-svg p-smooth"><input type="checkbox" id="checkbox-institutional-96705" checked="" name="institutional"/><div class="state"><svg class="svg-icon svg svg-icon" width="20" height="20" x="0px" y="0px" viewBox="0 0 20 20"><path d="M5.25 9.486L14.543 0 16 1.428 5.307 12.343 0 7.34l1.4-1.484z"></path></svg><label for="checkbox-institutional-96705"><span>Institutional</span></label></div></div></div></div><p class="gdpr-copy">By signing up, you will receive emails about CoinDesk products and you agree to our<!-- --> <a href="/terms" target="_blank">terms &amp; conditions</a> <!-- -->and<!-- --> <a href="/privacy" target="_blank">privacy policy</a></p></div><div class="singup-input-controls input-content"><input type="email" placeholder="Enter your mail" value=""/><div class="buttons"><button disabled="" class="button primary-button primary-button-default disabled">Sign Up</button></div></div><div class="error-content ">Please enter a valid email address</div></section></div></div></div></nav></li></ul><a class="events-button" href="/events">Events</a><ul class="top-nav search-nav"><li class="js-only "><button class="search-button " aria-label="Search"><svg class="svg-icon" width="22" height="21" x="0px" y="0px" viewBox="0 0 22 21"><path d="M15.9,14.1l5.4,5.4l-1.2,1.2l-5.4-5.4c-3.6,3.1-9,2.7-12.1-0.9S0,5.4,3.6,2.3s9-2.7,12.1,0.9 C18.4,6.3,18.5,10.9,15.9,14.1z M14,13.7c2.7-2.7,2.7-7,0-9.7S7,1.3,4.3,4l0,0c-2.7,2.7-2.7,7,0,9.7S11.4,16.3,14,13.7z"></path></svg></button><nav class="nav-expanded"><div class="container"><button class="button close-button"><img src="https://static.coindesk.com/images/close-icon-64f2495836d72706c350aea6c5bbe542.svg"/></button><div class="search &#x27;"><div class="search-wrapper"><div class="search-bar"><div class="input-wrapper"><form role="search"><input type="search" value="" placeholder="Search"/><a href="/search?q="><button class="search-button" aria-label="Search"><svg class="svg-icon" width="22" height="21" x="0px" y="0px" viewBox="0 0 22 21"><path d="M15.9,14.1l5.4,5.4l-1.2,1.2l-5.4-5.4c-3.6,3.1-9,2.7-12.1-0.9S0,5.4,3.6,2.3s9-2.7,12.1,0.9 C18.4,6.3,18.5,10.9,15.9,14.1z M14,13.7c2.7-2.7,2.7-7,0-9.7S7,1.3,4.3,4l0,0c-2.7,2.7-2.7,7,0,9.7S11.4,16.3,14,13.7z"></path></svg></button></a></form></div></div></div><div class="article-recirculation"><div class="article-container"><h2 class="article-recirculation-heading">Trending</h2></div><div class="recirculation"></div></div></div></div></nav></li><li class="no-js"><button class="search-button" aria-label="Search"><a href="/search"><svg class="svg-icon" width="22" height="21" x="0px" y="0px" viewBox="0 0 22 21"><path d="M15.9,14.1l5.4,5.4l-1.2,1.2l-5.4-5.4c-3.6,3.1-9,2.7-12.1-0.9S0,5.4,3.6,2.3s9-2.7,12.1,0.9 C18.4,6.3,18.5,10.9,15.9,14.1z M14,13.7c2.7-2.7,2.7-7,0-9.7S7,1.3,4.3,4l0,0c-2.7,2.7-2.7,7,0,9.7S11.4,16.3,14,13.7z"></path></svg></a></button></li></ul></div></div></div></nav><nav class="pricing-nav-desktop  minimized"><div class="pricing-wrapper-spacer"></div><nav class="pricing-wrapper"><div class="container"><div class="pricing-col"><a class="pricing-card minimized pre-animation-state"><div class="pricing-wrapper-minimized"><div class="title"><span> 24h</span></div><div class="pricing"><div class="price val-negative"><span class="symbol">$</span>0</div><div class="change-percent val-negative">NaN%</div></div></div><div class="pricing-card-wrapper hidden"><div class="half"><h5 class="title"> 24h</h5><hr/><div class="price val-negative"><span class="symbol">$</span>0</div></div><div class="half"><div class="change"><div class="change-value val-negative">n/a</div><div class="change-percent val-negative">NaN%</div></div><div class="graph"></div></div></div></a></div><div class="pricing-col"><a class="pricing-card minimized pre-animation-state"><div class="pricing-wrapper-minimized"><div class="title"><span> 24h</span></div><div class="pricing"><div class="price val-negative"><span class="symbol">$</span>0</div><div class="change-percent val-negative">NaN%</div></div></div><div class="pricing-card-wrapper hidden"><div class="half"><h5 class="title"> 24h</h5><hr/><div class="price val-negative"><span class="symbol">$</span>0</div></div><div class="half"><div class="change"><div class="change-value val-negative">n/a</div><div class="change-percent val-negative">NaN%</div></div><div class="graph"></div></div></div></a></div><div class="pricing-col"><a class="pricing-card minimized pre-animation-state"><div class="pricing-wrapper-minimized"><div class="title"><span> 24h</span></div><div class="pricing"><div class="price val-negative"><span class="symbol">$</span>0</div><div class="change-percent val-negative">NaN%</div></div></div><div class="pricing-card-wrapper hidden"><div class="half"><h5 class="title"> 24h</h5><hr/><div class="price val-negative"><span class="symbol">$</span>0</div></div><div class="half"><div class="change"><div class="change-value val-negative">n/a</div><div class="change-percent val-negative">NaN%</div></div><div class="graph"></div></div></div></a></div><div class="pricing-col"><a class="pricing-card minimized pre-animation-state"><div class="pricing-wrapper-minimized"><div class="title"><span> 24h</span></div><div class="pricing"><div class="price val-negative"><span class="symbol">$</span>0</div><div class="change-percent val-negative">NaN%</div></div></div><div class="pricing-card-wrapper hidden"><div class="half"><h5 class="title"> 24h</h5><hr/><div class="price val-negative"><span class="symbol">$</span>0</div></div><div class="half"><div class="change"><div class="change-value val-negative">n/a</div><div class="change-percent val-negative">NaN%</div></div><div class="graph"></div></div></div></a></div><div class="pricing-col"><a class="pricing-card minimized pre-animation-state"><div class="pricing-wrapper-minimized"><div class="title"><span> 24h</span></div><div class="pricing"><div class="price val-negative"><span class="symbol">$</span>0</div><div class="change-percent val-negative">NaN%</div></div></div><div class="pricing-card-wrapper hidden"><div class="half"><h5 class="title"> 24h</h5><hr/><div class="price val-negative"><span class="symbol">$</span>0</div></div><div class="half"><div class="change"><div class="change-value val-negative">n/a</div><div class="change-percent val-negative">NaN%</div></div><div class="graph"></div></div></div></a></div><div class="pricing-col"><a class="pricing-card minimized pre-animation-state"><div class="pricing-wrapper-minimized"><div class="title"><span> 24h</span></div><div class="pricing"><div class="price val-negative"><span class="symbol">$</span>0</div><div class="change-percent val-negative">NaN%</div></div></div><div class="pricing-card-wrapper hidden"><div class="half"><h5 class="title"> 24h</h5><hr/><div class="price val-negative"><span class="symbol">$</span>0</div></div><div class="half"><div class="change"><div class="change-value val-negative">n/a</div><div class="change-percent val-negative">NaN%</div></div><div class="graph"></div></div></div></a></div><div class="pricing-col"><a class="pricing-card minimized pre-animation-state"><div class="pricing-wrapper-minimized"><div class="title"><span> 24h</span></div><div class="pricing"><div class="price val-negative"><span class="symbol">$</span>0</div><div class="change-percent val-negative">NaN%</div></div></div><div class="pricing-card-wrapper hidden"><div class="half"><h5 class="title"> 24h</h5><hr/><div class="price val-negative"><span class="symbol">$</span>0</div></div><div class="half"><div class="change"><div class="change-value val-negative">n/a</div><div class="change-percent val-negative">NaN%</div></div><div class="graph"></div></div></div></a></div><div class="pricing-col"><a class="pricing-card minimized pre-animation-state"><div class="pricing-wrapper-minimized"><div class="title"><span> 24h</span></div><div class="pricing"><div class="price val-negative"><span class="symbol">$</span>0</div><div class="change-percent val-negative">NaN%</div></div></div><div class="pricing-card-wrapper hidden"><div class="half"><h5 class="title"> 24h</h5><hr/><div class="price val-negative"><span class="symbol">$</span>0</div></div><div class="half"><div class="change"><div class="change-value val-negative">n/a</div><div class="change-percent val-negative">NaN%</div></div><div class="graph"></div></div></div></a></div><div class="pricing-col"><a class="pricing-card minimized pre-animation-state"><div class="pricing-wrapper-minimized"><div class="title"><span> 24h</span></div><div class="pricing"><div class="price val-negative"><span class="symbol">$</span>0</div><div class="change-percent val-negative">NaN%</div></div></div><div class="pricing-card-wrapper hidden"><div class="half"><h5 class="title"> 24h</h5><hr/><div class="price val-negative"><span class="symbol">$</span>0</div></div><div class="half"><div class="change"><div class="change-value val-negative">n/a</div><div class="change-percent val-negative">NaN%</div></div><div class="graph"></div></div></div></a></div><div class="pricing-col"><a class="pricing-card minimized pre-animation-state"><div class="pricing-wrapper-minimized"><div class="title"><span> 24h</span></div><div class="pricing"><div class="price val-negative"><span class="symbol">$</span>0</div><div class="change-percent val-negative">NaN%</div></div></div><div class="pricing-card-wrapper hidden"><div class="half"><h5 class="title"> 24h</h5><hr/><div class="price val-negative"><span class="symbol">$</span>0</div></div><div class="half"><div class="change"><div class="change-value val-negative">n/a</div><div class="change-percent val-negative">NaN%</div></div><div class="graph"></div></div></div></a></div><div class="pricing-col"><a class="pricing-card minimized pre-animation-state"><div class="pricing-wrapper-minimized"><div class="title"><span> 24h</span></div><div class="pricing"><div class="price val-negative"><span class="symbol">$</span>0</div><div class="change-percent val-negative">NaN%</div></div></div><div class="pricing-card-wrapper hidden"><div class="half"><h5 class="title"> 24h</h5><hr/><div class="price val-negative"><span class="symbol">$</span>0</div></div><div class="half"><div class="change"><div class="change-value val-negative">n/a</div><div class="change-percent val-negative">NaN%</div></div><div class="graph"></div></div></div></a></div><div class="pricing-col"><a class="pricing-card minimized pre-animation-state"><div class="pricing-wrapper-minimized"><div class="title"><span> 24h</span></div><div class="pricing"><div class="price val-negative"><span class="symbol">$</span>0</div><div class="change-percent val-negative">NaN%</div></div></div><div class="pricing-card-wrapper hidden"><div class="half"><h5 class="title"> 24h</h5><hr/><div class="price val-negative"><span class="symbol">$</span>0</div></div><div class="half"><div class="change"><div class="change-value val-negative">n/a</div><div class="change-percent val-negative">NaN%</div></div><div class="graph"></div></div></div></a></div><div class="pricing-col"><a class="pricing-card minimized pre-animation-state"><div class="pricing-wrapper-minimized"><div class="title"><span> 24h</span></div><div class="pricing"><div class="price val-negative"><span class="symbol">$</span>0</div><div class="change-percent val-negative">NaN%</div></div></div><div class="pricing-card-wrapper hidden"><div class="half"><h5 class="title"> 24h</h5><hr/><div class="price val-negative"><span class="symbol">$</span>0</div></div><div class="half"><div class="change"><div class="change-value val-negative">n/a</div><div class="change-percent val-negative">NaN%</div></div><div class="graph"></div></div></div></a></div><div class="pricing-col"><a class="pricing-card minimized pre-animation-state"><div class="pricing-wrapper-minimized"><div class="title"><span> 24h</span></div><div class="pricing"><div class="price val-negative"><span class="symbol">$</span>0</div><div class="change-percent val-negative">NaN%</div></div></div><div class="pricing-card-wrapper hidden"><div class="half"><h5 class="title"> 24h</h5><hr/><div class="price val-negative"><span class="symbol">$</span>0</div></div><div class="half"><div class="change"><div class="change-value val-negative">n/a</div><div class="change-percent val-negative">NaN%</div></div><div class="graph"></div></div></div></a></div><div class="pricing-col"><a class="pricing-card minimized pre-animation-state"><div class="pricing-wrapper-minimized"><div class="title"><span> 24h</span></div><div class="pricing"><div class="price val-negative"><span class="symbol">$</span>0</div><div class="change-percent val-negative">NaN%</div></div></div><div class="pricing-card-wrapper hidden"><div class="half"><h5 class="title"> 24h</h5><hr/><div class="price val-negative"><span class="symbol">$</span>0</div></div><div class="half"><div class="change"><div class="change-value val-negative">n/a</div><div class="change-percent val-negative">NaN%</div></div><div class="graph"></div></div></div></a></div><div class="pricing-col"><a class="pricing-card minimized pre-animation-state"><div class="pricing-wrapper-minimized"><div class="title"><span> 24h</span></div><div class="pricing"><div class="price val-negative"><span class="symbol">$</span>0</div><div class="change-percent val-negative">NaN%</div></div></div><div class="pricing-card-wrapper hidden"><div class="half"><h5 class="title"> 24h</h5><hr/><div class="price val-negative"><span class="symbol">$</span>0</div></div><div class="half"><div class="change"><div class="change-value val-negative">n/a</div><div class="change-percent val-negative">NaN%</div></div><div class="graph"></div></div></div></a></div><div class="pricing-col"><a class="pricing-card minimized pre-animation-state"><div class="pricing-wrapper-minimized"><div class="title"><span> 24h</span></div><div class="pricing"><div class="price val-negative"><span class="symbol">$</span>0</div><div class="change-percent val-negative">NaN%</div></div></div><div class="pricing-card-wrapper hidden"><div class="half"><h5 class="title"> 24h</h5><hr/><div class="price val-negative"><span class="symbol">$</span>0</div></div><div class="half"><div class="change"><div class="change-value val-negative">n/a</div><div class="change-percent val-negative">NaN%</div></div><div class="graph"></div></div></div></a></div><div class="pricing-col"><a class="pricing-card minimized pre-animation-state"><div class="pricing-wrapper-minimized"><div class="title"><span> 24h</span></div><div class="pricing"><div class="price val-negative"><span class="symbol">$</span>0</div><div class="change-percent val-negative">NaN%</div></div></div><div class="pricing-card-wrapper hidden"><div class="half"><h5 class="title"> 24h</h5><hr/><div class="price val-negative"><span class="symbol">$</span>0</div></div><div class="half"><div class="change"><div class="change-value val-negative">n/a</div><div class="change-percent val-negative">NaN%</div></div><div class="graph"></div></div></div></a></div><div class="pricing-col"><a class="pricing-card minimized pre-animation-state"><div class="pricing-wrapper-minimized"><div class="title"><span> 24h</span></div><div class="pricing"><div class="price val-negative"><span class="symbol">$</span>0</div><div class="change-percent val-negative">NaN%</div></div></div><div class="pricing-card-wrapper hidden"><div class="half"><h5 class="title"> 24h</h5><hr/><div class="price val-negative"><span class="symbol">$</span>0</div></div><div class="half"><div class="change"><div class="change-value val-negative">n/a</div><div class="change-percent val-negative">NaN%</div></div><div class="graph"></div></div></div></a></div><div class="pricing-col"><a class="pricing-card minimized pre-animation-state"><div class="pricing-wrapper-minimized"><div class="title"><span> 24h</span></div><div class="pricing"><div class="price val-negative"><span class="symbol">$</span>0</div><div class="change-percent val-negative">NaN%</div></div></div><div class="pricing-card-wrapper hidden"><div class="half"><h5 class="title"> 24h</h5><hr/><div class="price val-negative"><span class="symbol">$</span>0</div></div><div class="half"><div class="change"><div class="change-value val-negative">n/a</div><div class="change-percent val-negative">NaN%</div></div><div class="graph"></div></div></div></a></div><div class="pricing-col"><a class="pricing-card minimized pre-animation-state"><div class="pricing-wrapper-minimized"><div class="title"><span> 24h</span></div><div class="pricing"><div class="price val-negative"><span class="symbol">$</span>0</div><div class="change-percent val-negative">NaN%</div></div></div><div class="pricing-card-wrapper hidden"><div class="half"><h5 class="title"> 24h</h5><hr/><div class="price val-negative"><span class="symbol">$</span>0</div></div><div class="half"><div class="change"><div class="change-value val-negative">n/a</div><div class="change-percent val-negative">NaN%</div></div><div class="graph"></div></div></div></a></div><div class="pricing-col"><a class="pricing-card minimized pre-animation-state"><div class="pricing-wrapper-minimized"><div class="title"><span> 24h</span></div><div class="pricing"><div class="price val-negative"><span class="symbol">$</span>0</div><div class="change-percent val-negative">NaN%</div></div></div><div class="pricing-card-wrapper hidden"><div class="half"><h5 class="title"> 24h</h5><hr/><div class="price val-negative"><span class="symbol">$</span>0</div></div><div class="half"><div class="change"><div class="change-value val-negative">n/a</div><div class="change-percent val-negative">NaN%</div></div><div class="graph"></div></div></div></a></div><div class="clearfix"></div></div><div class="pricing-nav-controls"><div class="toggle-wrapper"><button class="toggle-pricing  minimized"><svg class="chevron-arrow" width="22" height="11" viewBox="0 0 22 11"><path d="M21.7,1L11,11L0.3,1"></path></svg></button></div></div></nav></nav><div class="ie-banner light"><div class="banner-content"><p>Please consider using a different web browser for better experience.</p><div class="close-banner"><svg class="svg-icon" x="0px" y="0px" viewBox="0 0 20 20"><line x1="20" y1="0" x2="0" y2="20"></line><line x1="20" y1="20" x2="0" y2="0"></line></svg></div></div></div></div><div class="notification no-js"><span><strong>Please enable JavaScript in your browser for a better site experience.</strong></span></div></header></section><main><section style="background-image:url(&quot;https://static.coindesk.com/images/article_bg-dab68b5a23178635c5b544c04ad28252.png&quot;)" class="global-content article "><div class="articles article-module"><article id="article-439788" class="article "><header class="article-hero news has-media pre-animation-state"><div><div class="article-hero-nav"><a href="/category/tech"><button class="button related-button"><span class="related-button-text"><span class="article-type">story</span> from <strong>Tech</strong></span><svg class="svg-icon" x="0px" y="0px" viewBox="0 0 18 12" width="18" height="12"><g fill-rule="nonzero"><path d="M16.1 6.5H0v-1h16.1L11.64.846l.72-.692L17.966 6l-5.604 5.846-.722-.692L16.101 6.5z"></path></g></svg></button></a></div><div class="article-hero-content"><div class="article-hero-meta"><div class="article-hero-title"><h1 class="heading ">IOTA Fixes ‘Minor’ Network Bug  Following 15-Hour Mainnet Downtime</h1><div class="timestamps"><time dateTime="2019-12-30T13:40:00">Dec 30, 2019 at 13:40 UTC</time><span class="divider"></span><time dateTime="2019-12-30T14:56:21">Updated Dec 30, 2019 at 14:56 UTC</time></div><div class="sharing"><a href="https://twitter.com/intent/tweet?text=IOTA%20Fixes%20%E2%80%98Minor%E2%80%99%20Network%20Bug%20%20Following%2015-Hour%20Mainnet%20Downtime%20https%3A%2F%2Fwww.coindesk.com%2Fiota-fixes-minor-network-bug-following-15-hour-mainnet-downtime%20via%20%40coindesk" target="_blank" rel="noopener noreferrer" class="twitter" title="Share on Twitter"><svg class="svg-icon" viewBox="0 0 24 24"><path fill="#fff" d="M24 4.557c-.883.392-1.832.656-2.828.775 1.017-.609 1.798-1.574 2.165-2.724-.951.564-2.005.974-3.127 1.195-.897-.957-2.178-1.555-3.594-1.555-3.179 0-5.515 2.966-4.797 6.045-4.091-.205-7.719-2.165-10.148-5.144-1.29 2.213-.669 5.108 1.523 6.574-.806-.026-1.566-.247-2.229-.616-.054 2.281 1.581 4.415 3.949 4.89-.693.188-1.452.232-2.224.084.626 1.956 2.444 3.379 4.6 3.419-2.07 1.623-4.678 2.348-7.29 2.04 2.179 1.397 4.768 2.212 7.548 2.212 9.142 0 14.307-7.721 13.995-14.646.962-.695 1.797-1.562 2.457-2.549z"></path></svg></a><a href="https://www.facebook.com/sharer/sharer.php?u=https://www.coindesk.com/iota-fixes-minor-network-bug-following-15-hour-mainnet-downtime" target="_blank" rel="noopener noreferrer" class="facebook" title="Share on Facebook"><svg class="svg-icon" width="24" height="24" viewBox="0 0 24 24"><path d="M9 8h-3v4h3v12h5v-12h3.642l.358-4h-4v-1.667c0-.955.192-1.333 1.115-1.333h2.885v-5h-3.808c-3.596 0-5.192 1.583-5.192 4.615v3.385z"></path></svg></a><a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Fwww.coindesk.com%2Fiota-fixes-minor-network-bug-following-15-hour-mainnet-downtime&amp;title=IOTA%20Fixes%20%E2%80%98Minor%E2%80%99%20Network%20Bug%20%20Following%2015-Hour%20Mainnet%20Downtime&amp;summary=CoinDesk%20-%20Leader%20in%20blockchain%20news.&amp;source=https%3A%2F%2Fwww.coindesk.com" target="_blank" rel="noopener noreferrer" class="linkedin" title="Share on LinkedIn"><svg class="svg-icon" viewBox="0 0 24 24"><path d="M4.98 3.5c0 1.381-1.11 2.5-2.48 2.5s-2.48-1.119-2.48-2.5c0-1.38 1.11-2.5 2.48-2.5s2.48 1.12 2.48 2.5zm.02 4.5h-5v16h5v-16zm7.982 0h-4.968v16h4.969v-8.399c0-4.67 6.029-5.052 6.029 0v8.399h4.988v-10.131c0-7.88-8.922-7.593-11.018-3.714v-2.155z"></path></svg></a></div></div></div><div class="article-hero-media"><div class="media-wrapper"><div class="fade"><picture><img loading="lazy" src="https://static.coindesk.com/wp-content/uploads/2018/08/norway-710x458.jpg" alt="https://www.shutterstock.com/image-photo/background-big-red-flashing-alarm-lights-1042134532?src=xzJN0HDnCw0EsoXIydd4Wg-1-27"/></picture></div></div><p class="media-source">Image via Shutterstock</p></div><div class="article-hero-authors"><div class="rects"><svg width="4" height="4" class="rect"><rect width="4" height="4"></rect></svg><svg width="4" height="4" class="rect"><rect width="4" height="4"></rect></svg><svg width="4" height="4" class="rect"><rect width="4" height="4"></rect></svg></div><section class="sidebar-profile  author"><div class="img-block"><a style="background:linear-gradient(to bottom, rgba(0, 0, 0, 0.2), rgba(0, 0, 0, 0.2)),linear-gradient(to bottom, #19284d, #19284d),url(&quot;https://static.coindesk.com/wp-content/uploads/2019/11/Paddy-Baker.jpg&quot;);background-size:cover;background-position:center" href="/author/paddy-baker"></a></div><div class="text-block"><a href="/author/paddy-baker"><h5 class="heading">Paddy Baker</h5></a><div class="social-accounts"><a href="https://www.twitter.com/paddybaker_" target="_blank" rel="noopener noreferrer"><svg class="svg-icon" viewBox="0 0 24 24"><path fill="#fff" d="M24 4.557c-.883.392-1.832.656-2.828.775 1.017-.609 1.798-1.574 2.165-2.724-.951.564-2.005.974-3.127 1.195-.897-.957-2.178-1.555-3.594-1.555-3.179 0-5.515 2.966-4.797 6.045-4.091-.205-7.719-2.165-10.148-5.144-1.29 2.213-.669 5.108 1.523 6.574-.806-.026-1.566-.247-2.229-.616-.054 2.281 1.581 4.415 3.949 4.89-.693.188-1.452.232-2.224.084.626 1.956 2.444 3.379 4.6 3.419-2.07 1.623-4.678 2.348-7.29 2.04 2.179 1.397 4.768 2.212 7.548 2.212 9.142 0 14.307-7.721 13.995-14.646.962-.695 1.797-1.562 2.457-2.549z"></path></svg></a><a href="mailto:paddy@coindesk.com" target="_blank" rel="noopener noreferrer"><svg class="svg-icon" viewBox="0 0 20 20"><path d="M19.7,5C19.9,5.3,20,5.6,20,5.9v10.2c0,1-0.8,1.9-1.8,1.9H1.8c-1,0-1.8-0.8-1.8-1.9V5.9 C0,5.6,0.1,5.3,0.3,5l9.4,7.8c0.2,0.1,0.4,0.1,0.6,0L19.7,5L19.7,5z M19,3.3L10,11L1,3.3C1.3,3.1,1.6,3,1.9,3h16.2 C18.4,3,18.7,3.1,19,3.3z"></path><g><path d="M19.7,5C19.9,5.3,20,5.6,20,5.9v10.2c0,1-0.8,1.9-1.8,1.9H1.8c-1,0-1.8-0.8-1.8-1.9V5.9 C0,5.6,0.1,5.3,0.3,5l9.4,7.8c0.2,0.1,0.4,0.1,0.6,0L19.7,5L19.7,5z M19,3.3L10,11L1,3.3C1.3,3.1,1.6,3,1.9,3h16.2 C18.4,3,18.7,3.1,19,3.3z"></path></g></svg></a></div><hr/></div></section></div></div></div></header><div class="article-progress-bar "><div class="pb-content"><div class="container"><h2 class="heading truncate">IOTA Fixes ‘Minor’ Network Bug  Following 15-Hour Mainnet Downtime</h2><div class="space"></div><div class="icons"><div class="social-share custom"><a href="https://twitter.com/intent/tweet?text=IOTA%20Fixes%20%E2%80%98Minor%E2%80%99%20Network%20Bug%20%20Following%2015-Hour%20Mainnet%20Downtime%20https%3A%2F%2Fwww.coindesk.com%2Fiota-fixes-minor-network-bug-following-15-hour-mainnet-downtime%20via%20%40coindesk" target="_blank" rel="noopener noreferrer" class="twitter" title="Share on Twitter"><svg class="svg-icon" viewBox="0 0 24 24"><path fill="#fff" d="M24 4.557c-.883.392-1.832.656-2.828.775 1.017-.609 1.798-1.574 2.165-2.724-.951.564-2.005.974-3.127 1.195-.897-.957-2.178-1.555-3.594-1.555-3.179 0-5.515 2.966-4.797 6.045-4.091-.205-7.719-2.165-10.148-5.144-1.29 2.213-.669 5.108 1.523 6.574-.806-.026-1.566-.247-2.229-.616-.054 2.281 1.581 4.415 3.949 4.89-.693.188-1.452.232-2.224.084.626 1.956 2.444 3.379 4.6 3.419-2.07 1.623-4.678 2.348-7.29 2.04 2.179 1.397 4.768 2.212 7.548 2.212 9.142 0 14.307-7.721 13.995-14.646.962-.695 1.797-1.562 2.457-2.549z"></path></svg></a><a href="https://www.facebook.com/sharer/sharer.php?u=https://www.coindesk.com/iota-fixes-minor-network-bug-following-15-hour-mainnet-downtime" target="_blank" rel="noopener noreferrer" class="facebook" title="Share on Facebook"><svg class="svg-icon" width="24" height="24" viewBox="0 0 24 24"><path d="M9 8h-3v4h3v12h5v-12h3.642l.358-4h-4v-1.667c0-.955.192-1.333 1.115-1.333h2.885v-5h-3.808c-3.596 0-5.192 1.583-5.192 4.615v3.385z"></path></svg></a><a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Fwww.coindesk.com%2Fiota-fixes-minor-network-bug-following-15-hour-mainnet-downtime&amp;title=IOTA%20Fixes%20%E2%80%98Minor%E2%80%99%20Network%20Bug%20%20Following%2015-Hour%20Mainnet%20Downtime&amp;summary=CoinDesk%20-%20Leader%20in%20blockchain%20news.&amp;source=https%3A%2F%2Fwww.coindesk.com" target="_blank" rel="noopener noreferrer" class="linkedin" title="Share on LinkedIn"><svg class="svg-icon" viewBox="0 0 24 24"><path d="M4.98 3.5c0 1.381-1.11 2.5-2.48 2.5s-2.48-1.119-2.48-2.5c0-1.38 1.11-2.5 2.48-2.5s2.48 1.12 2.48 2.5zm.02 4.5h-5v16h5v-16zm7.982 0h-4.968v16h4.969v-8.399c0-4.67 6.029-5.052 6.029 0v8.399h4.988v-10.131c0-7.88-8.922-7.593-11.018-3.714v-2.155z"></path></svg></a></div></div></div></div><div class="progress" style="width:0%"></div></div><section class="article-content has-media"><section class="article-body has-media"><div id="node-0" class="article-pharagraph"><p class="text ">The IOTA Foundation said it has resolved a software bug that prevented transactions from confirming on the IOTA network for 15 hours. </p></div><div id="node-1" class="article-pharagraph"><p class="text "><a href="https://github.com/iotaledger/iri/releases/tag/v1.8.3-RELEASE" target="_blank" rel="noopener noreferrer" data-reactroot="">According to</a> a GitHub submission from an IOTA developer Sunday night UTC, a bug in the node software created a "corrupt ledger state."</p></div><div id="node-2" class="article-pharagraph"><p class="text ">"There is an edge case where IRI [IOTA Reference Implementation] didn't account for a transaction that was shared between two distinct bundles. Once it marked it as 'counted' in one bundle, it was ignored for the next bundle," the GitHub post reads. </p></div><div id="node-3" class="article-pharagraph"><p class="text ">Users first reported the problem on Sunday, which took IOTA's engineering team some 15 hours to fix. IOTA founder David Sønstebø <a href="https://twitter.com/Vrom14286662/status/1211267460546080768" target="_blank" rel="noopener noreferrer" data-reactroot="">said</a> the bug was "minor" and "it's really no different from periods where the network has been spammed and thus real tx [transactions] slowed down significantly".</p></div><div id="node-4" class="article-pharagraph"><p class="text ">IOTA has asked users running IRI nodes to update to a new software version that patches the bug. </p></div><div id="node-5" class="article-pharagraph"><p class="text ">IOTA's co-founder Dominik Schiener said in an email the issue originated with the "current primary mainnet node software" and had nothing to do with the Coordinator, a special node that's operated by the Foundation, which is responsible for the final confirmation of transactions on IOTA's decentralized network, known as the Tangle. </p></div><div id="node-6" class="article-pharagraph"><p class="text ">The team has already <a href="https://blog.iota.org/introducing-hornet-a-lightweight-iota-node-2b3b750348f5" target="_blank" rel="noopener noreferrer" data-reactroot="">started</a> to replace it with a new lightweight node, known as Hornet, and said it plans to remove the Coordinator once engineers have fully tested and resolved any possible network problems with an event known as the "Coordicide."  </p></div><div id="node-7" class="article-pharagraph"><p class="text ">Following reports on the bug in the network on Sunday, Sønstebø defended the current set-up, arguing this was "precisely why Coordicide takes time, one can't execute it until all possible kinks have been ironed out."</p></div><div id="node-8" class="article-pharagraph"><p class="text ">Nonetheless, critics have already argued the centralized nature of Tangle curtails performance and makes it vulnerable. </p></div><div id="node-9" class="article-pharagraph"><p class="text ">In 2018, blockchain researcher Joseph Rebstock <a href="https://thenextweb.com/hardfork/2018/02/21/iota-replay-attacks-vulnerability/" target="_blank" rel="noopener noreferrer" data-reactroot="">told</a> The Next Web the Coordinator automatically approves the same hash, meaning hackers could steal cryptocurrency from users who reused wallet addresses by repeating transaction data. Sønstebø later denied this was a vulnerability. </p></div><div id="node-10" class="article-pharagraph"><p class="text ">In an email Monday, Schiener wrote: "Coordicide is proceeding unchanged, with the first alpha test happening in January."&nbsp;</p></div><div id="node-11" class="article-pharagraph"><p class="text ">The IOTA Foundation designed Tangle as a transaction platform for new internet of things (IoT) initiatives. The Taiwanese capital of Taipei <a href="https://www.coindesk.com/city-of-taipei-confirms-its-testing-iota-blockchain-for-id" data-reactroot="">partnered</a> with IOTA in early 2018 to test a new tamper-proof citizen identification system. </p></div><div id="node-12" class="article-pharagraph"><p class="text ">In April 2019, Jaguar Land Rover <a href="https://www.coindesk.com/jaguar-land-rover-plans-to-give-drivers-crypto-in-return-for-their-data" data-reactroot="">revealed</a> it was trialling an incentive scheme to reward drivers who reported road condition data with iota tokens. </p></div><div class="end"><i class="pentagon"></i></div><div class="tags"><h4>Read more about...</h4><span class="tag"><a href="/tag/iota">IOTA</a></span><span class="tag"><a href="/tag/bug">Bug</a></span></div><div class="article-disclosure"><details><summary class="heading">Disclosure<!-- --> <a>Read <!-- -->More<!-- --> </a></summary><p>The leader in blockchain news, CoinDesk is a media outlet that strives for the highest journalistic standards and abides by a <a target="_blank" href="/editorial-policy" data-reactroot="">strict set of editorial policies</a>. CoinDesk is an independent operating subsidiary of Digital Currency Group, which invests in cryptocurrencies and blockchain startups.</p></details></div></section></section></article><div class="article-recirculation"><div class="article-container"><h2 class="article-recirculation-heading">Related</h2></div><div class="recirculation"><div class="recirculation-desktop"><div class="recirculation-container"><ul class="recirculation-desktop-wrapper" style="width:1432px;transform:translateX(-432px)"><li style="margin-right:48px"><div><section class="article-card "><div class="decoration"></div><div class="card-img-block"><a title="Thanks to Better UX, This Year Dapps Will Go Mainstream" href="/thanks-to-better-ux-this-year-dapps-will-go-mainstream"><picture><img src="https://static.coindesk.com/wp-content/uploads/2019/12/Jason-Goldberg-710x458.jpg" alt="" loading="lazy" class="article-card-img"/></picture></a><a class="button eyebrow-button" href="/tag/year-in-review-2019"><span class="eyebrow-button-text">Year in Review 2019</span><svg class="svg-icon" x="0px" y="0px" viewBox="0 0 18 12" width="18" height="12"><g fill-rule="nonzero"><path d="M16.1 6.5H0v-1h16.1L11.64.846l.72-.692L17.966 6l-5.604 5.846-.722-.692L16.101 6.5z"></path></g></svg></a></div><div class="card-text-block"><h4 class="heading"><a title="Thanks to Better UX, This Year Dapps Will Go Mainstream" href="/thanks-to-better-ux-this-year-dapps-will-go-mainstream">Thanks to Better UX, This Year Dapps Will Go Mainstream</a> <a href="https://twitter.com/intent/tweet?text=Thanks%20to%20Better%20UX%2C%20This%20Year%20Dapps%20Will%20Go%20Mainstream%20https%3A%2F%2Fwww.coindesk.com%2Fthanks-to-better-ux-this-year-dapps-will-go-mainstream%20via%20%40coindesk" target="_blank" rel="noopener noreferrer" class="twitter" title="Share on Twitter"><svg class="svg-icon" viewBox="0 0 24 24"><path fill="#fff" d="M24 4.557c-.883.392-1.832.656-2.828.775 1.017-.609 1.798-1.574 2.165-2.724-.951.564-2.005.974-3.127 1.195-.897-.957-2.178-1.555-3.594-1.555-3.179 0-5.515 2.966-4.797 6.045-4.091-.205-7.719-2.165-10.148-5.144-1.29 2.213-.669 5.108 1.523 6.574-.806-.026-1.566-.247-2.229-.616-.054 2.281 1.581 4.415 3.949 4.89-.693.188-1.452.232-2.224.084.626 1.956 2.444 3.379 4.6 3.419-2.07 1.623-4.678 2.348-7.29 2.04 2.179 1.397 4.768 2.212 7.548 2.212 9.142 0 14.307-7.721 13.995-14.646.962-.695 1.797-1.562 2.457-2.549z"></path></svg></a></h4><div class="card-desc"><span class="card-author"><a title="Articles by Jason Goldberg" href="/author/jason-goldberg">Jason Goldberg</a></span><span class="card-date">Dec 30, 2019</span></div></div></section></div></li><li style="margin-right:48px"><div><section class="article-card "><div class="decoration"></div><div class="card-img-block"><a title="AI For Everyone: Super-Smart Systems That Reward Data Creators" href="/ai-for-everyone-super-smart-systems-that-reward-data-creators"><picture><img src="https://static.coindesk.com/wp-content/uploads/2019/12/Ben-G-pic-710x458.jpg" alt="" loading="lazy" class="article-card-img"/></picture></a><a class="button eyebrow-button" href="/tag/year-in-review-2019"><span class="eyebrow-button-text">Year in Review 2019</span><svg class="svg-icon" x="0px" y="0px" viewBox="0 0 18 12" width="18" height="12"><g fill-rule="nonzero"><path d="M16.1 6.5H0v-1h16.1L11.64.846l.72-.692L17.966 6l-5.604 5.846-.722-.692L16.101 6.5z"></path></g></svg></a></div><div class="card-text-block"><h4 class="heading"><a title="AI For Everyone: Super-Smart Systems That Reward Data Creators" href="/ai-for-everyone-super-smart-systems-that-reward-data-creators">AI For Everyone: Super-Smart Systems That Reward Data Creators</a> <a href="https://twitter.com/intent/tweet?text=AI%20For%20Everyone%3A%20Super-Smart%20Systems%20That%20Reward%20Data%20Creators%20https%3A%2F%2Fwww.coindesk.com%2Fai-for-everyone-super-smart-systems-that-reward-data-creators%20via%20%40coindesk" target="_blank" rel="noopener noreferrer" class="twitter" title="Share on Twitter"><svg class="svg-icon" viewBox="0 0 24 24"><path fill="#fff" d="M24 4.557c-.883.392-1.832.656-2.828.775 1.017-.609 1.798-1.574 2.165-2.724-.951.564-2.005.974-3.127 1.195-.897-.957-2.178-1.555-3.594-1.555-3.179 0-5.515 2.966-4.797 6.045-4.091-.205-7.719-2.165-10.148-5.144-1.29 2.213-.669 5.108 1.523 6.574-.806-.026-1.566-.247-2.229-.616-.054 2.281 1.581 4.415 3.949 4.89-.693.188-1.452.232-2.224.084.626 1.956 2.444 3.379 4.6 3.419-2.07 1.623-4.678 2.348-7.29 2.04 2.179 1.397 4.768 2.212 7.548 2.212 9.142 0 14.307-7.721 13.995-14.646.962-.695 1.797-1.562 2.457-2.549z"></path></svg></a></h4><div class="card-desc"><span class="card-author"><a title="Articles by Ben Goertzel" href="/author/ben-goertzel">Ben Goertzel</a></span><span class="card-date">Dec 30, 2019</span></div></div></section></div></li><li style="margin-right:48px"><div><section class="article-card "><div class="decoration"></div><div class="card-img-block"><a title="Korea’s Tax Agency to Withhold $70M From Crypto Exchange Bithumb" href="/koreas-tax-agency-to-withhold-70m-from-crypto-exchange-bithumb"><picture><img src="https://static.coindesk.com/wp-content/uploads/2018/10/Korean-won-and-bitcoin-710x458.jpg" alt="https://www.shutterstock.com/image-photo/golden-bitcoin-on-south-korea-won-767226415?src=OSVkoJB4f72YYKMYjYPEQQ-1-18" loading="lazy" class="article-card-img"/></picture></a><a class="button eyebrow-button" href="/tag/markets-exchanges"><span class="eyebrow-button-text">Exchanges</span><svg class="svg-icon" x="0px" y="0px" viewBox="0 0 18 12" width="18" height="12"><g fill-rule="nonzero"><path d="M16.1 6.5H0v-1h16.1L11.64.846l.72-.692L17.966 6l-5.604 5.846-.722-.692L16.101 6.5z"></path></g></svg></a></div><div class="card-text-block"><h4 class="heading"><a title="Korea’s Tax Agency to Withhold $70M From Crypto Exchange Bithumb" href="/koreas-tax-agency-to-withhold-70m-from-crypto-exchange-bithumb">Korea’s Tax Agency to Withhold $70M From Crypto Exchange Bithumb</a> <a href="https://twitter.com/intent/tweet?text=Korea%E2%80%99s%20Tax%20Agency%20to%20Withhold%20%2470M%20From%20Crypto%20Exchange%20Bithumb%20https%3A%2F%2Fwww.coindesk.com%2Fkoreas-tax-agency-to-withhold-70m-from-crypto-exchange-bithumb%20via%20%40coindesk" target="_blank" rel="noopener noreferrer" class="twitter" title="Share on Twitter"><svg class="svg-icon" viewBox="0 0 24 24"><path fill="#fff" d="M24 4.557c-.883.392-1.832.656-2.828.775 1.017-.609 1.798-1.574 2.165-2.724-.951.564-2.005.974-3.127 1.195-.897-.957-2.178-1.555-3.594-1.555-3.179 0-5.515 2.966-4.797 6.045-4.091-.205-7.719-2.165-10.148-5.144-1.29 2.213-.669 5.108 1.523 6.574-.806-.026-1.566-.247-2.229-.616-.054 2.281 1.581 4.415 3.949 4.89-.693.188-1.452.232-2.224.084.626 1.956 2.444 3.379 4.6 3.419-2.07 1.623-4.678 2.348-7.29 2.04 2.179 1.397 4.768 2.212 7.548 2.212 9.142 0 14.307-7.721 13.995-14.646.962-.695 1.797-1.562 2.457-2.549z"></path></svg></a></h4><div class="card-desc"><span class="card-author"><a title="Articles by Anna Baydakova" href="/author/abaydakova">Anna Baydakova</a></span><span class="card-date">Dec 30, 2019</span></div></div></section></div></li><li style="margin-right:48px"><div><section class="article-card "><div class="decoration"></div><div class="card-img-block"><a title="Huobi Indonesia Adds Fiat-to-Crypto Gateway in Bid for Global Expansion" href="/huobi-indonesia-adds-fiat-to-crypto-gateway-in-bid-for-global-expansion"><picture><img src="https://static.coindesk.com/wp-content/uploads/2019/12/shutterstock_1056505835-710x458.jpg" alt="" loading="lazy" class="article-card-img"/></picture></a><a class="button eyebrow-button" href="/tag/huobi"><span class="eyebrow-button-text">Huobi</span><svg class="svg-icon" x="0px" y="0px" viewBox="0 0 18 12" width="18" height="12"><g fill-rule="nonzero"><path d="M16.1 6.5H0v-1h16.1L11.64.846l.72-.692L17.966 6l-5.604 5.846-.722-.692L16.101 6.5z"></path></g></svg></a></div><div class="card-text-block"><h4 class="heading"><a title="Huobi Indonesia Adds Fiat-to-Crypto Gateway in Bid for Global Expansion" href="/huobi-indonesia-adds-fiat-to-crypto-gateway-in-bid-for-global-expansion">Huobi Indonesia Adds Fiat-to-Crypto Gateway in Bid for Global Expansion</a> <a href="https://twitter.com/intent/tweet?text=Huobi%20Indonesia%20Adds%20Fiat-to-Crypto%20Gateway%20in%20Bid%20for%20Global%20Expansion%20https%3A%2F%2Fwww.coindesk.com%2Fhuobi-indonesia-adds-fiat-to-crypto-gateway-in-bid-for-global-expansion%20via%20%40coindesk" target="_blank" rel="noopener noreferrer" class="twitter" title="Share on Twitter"><svg class="svg-icon" viewBox="0 0 24 24"><path fill="#fff" d="M24 4.557c-.883.392-1.832.656-2.828.775 1.017-.609 1.798-1.574 2.165-2.724-.951.564-2.005.974-3.127 1.195-.897-.957-2.178-1.555-3.594-1.555-3.179 0-5.515 2.966-4.797 6.045-4.091-.205-7.719-2.165-10.148-5.144-1.29 2.213-.669 5.108 1.523 6.574-.806-.026-1.566-.247-2.229-.616-.054 2.281 1.581 4.415 3.949 4.89-.693.188-1.452.232-2.224.084.626 1.956 2.444 3.379 4.6 3.419-2.07 1.623-4.678 2.348-7.29 2.04 2.179 1.397 4.768 2.212 7.548 2.212 9.142 0 14.307-7.721 13.995-14.646.962-.695 1.797-1.562 2.457-2.549z"></path></svg></a></h4><div class="card-desc"><span class="card-author"><a title="Articles by Daniel Kuhn" href="/author/danielcoindesk-com">Daniel Kuhn</a></span><span class="card-date">Dec 30, 2019</span></div></div></section></div></li><li style="margin-right:48px"><div><section class="article-card "><div class="decoration"></div><div class="card-img-block"><a title="China May Soon Have Its First Blockchain Exchange-Traded Fund" href="/china-may-soon-have-its-first-blockchain-exchange-traded-fund"><picture><img src="https://static.coindesk.com/wp-content/uploads/2018/03/china-flag-710x458.jpg" alt="https://www.shutterstock.com/image-photo/prague-czech-republic-march-28th-2016-398225560?src=133c1e53-74fc-4b44-914d-e6b74a5a1ee9-4-61&amp;studio=1" loading="lazy" class="article-card-img"/></picture></a><a class="button eyebrow-button" href="/tag/china"><span class="eyebrow-button-text">China</span><svg class="svg-icon" x="0px" y="0px" viewBox="0 0 18 12" width="18" height="12"><g fill-rule="nonzero"><path d="M16.1 6.5H0v-1h16.1L11.64.846l.72-.692L17.966 6l-5.604 5.846-.722-.692L16.101 6.5z"></path></g></svg></a></div><div class="card-text-block"><h4 class="heading"><a title="China May Soon Have Its First Blockchain Exchange-Traded Fund" href="/china-may-soon-have-its-first-blockchain-exchange-traded-fund">China May Soon Have Its First Blockchain Exchange-Traded Fund</a> <a href="https://twitter.com/intent/tweet?text=China%20May%20Soon%20Have%20Its%20First%20Blockchain%20Exchange-Traded%20Fund%20https%3A%2F%2Fwww.coindesk.com%2Fchina-may-soon-have-its-first-blockchain-exchange-traded-fund%20via%20%40coindesk" target="_blank" rel="noopener noreferrer" class="twitter" title="Share on Twitter"><svg class="svg-icon" viewBox="0 0 24 24"><path fill="#fff" d="M24 4.557c-.883.392-1.832.656-2.828.775 1.017-.609 1.798-1.574 2.165-2.724-.951.564-2.005.974-3.127 1.195-.897-.957-2.178-1.555-3.594-1.555-3.179 0-5.515 2.966-4.797 6.045-4.091-.205-7.719-2.165-10.148-5.144-1.29 2.213-.669 5.108 1.523 6.574-.806-.026-1.566-.247-2.229-.616-.054 2.281 1.581 4.415 3.949 4.89-.693.188-1.452.232-2.224.084.626 1.956 2.444 3.379 4.6 3.419-2.07 1.623-4.678 2.348-7.29 2.04 2.179 1.397 4.768 2.212 7.548 2.212 9.142 0 14.307-7.721 13.995-14.646.962-.695 1.797-1.562 2.457-2.549z"></path></svg></a></h4><div class="card-desc"><span class="card-author"><a title="Articles by Wolfie Zhao" href="/author/wolfiez">Wolfie Zhao</a></span><span class="card-date">Dec 30, 2019</span></div></div></section></div></li><li style="margin-right:48px"><div><section class="article-card "><div class="decoration"></div><div class="card-img-block"><a title="Data Creators Should Share in the Profits From Big Data" href="/data-creators-should-share-in-the-profits-from-big-data"><picture><img src="https://static.coindesk.com/wp-content/uploads/2019/12/Alex_head-710x458.jpg" alt="" loading="lazy" class="article-card-img"/></picture></a><a class="button eyebrow-button" href="/tag/year-in-review-2019"><span class="eyebrow-button-text">Year in Review 2019</span><svg class="svg-icon" x="0px" y="0px" viewBox="0 0 18 12" width="18" height="12"><g fill-rule="nonzero"><path d="M16.1 6.5H0v-1h16.1L11.64.846l.72-.692L17.966 6l-5.604 5.846-.722-.692L16.101 6.5z"></path></g></svg></a></div><div class="card-text-block"><h4 class="heading"><a title="Data Creators Should Share in the Profits From Big Data" href="/data-creators-should-share-in-the-profits-from-big-data">Data Creators Should Share in the Profits From Big Data</a> <a href="https://twitter.com/intent/tweet?text=Data%20Creators%20Should%20Share%20in%20the%20Profits%20From%20Big%20Data%20https%3A%2F%2Fwww.coindesk.com%2Fdata-creators-should-share-in-the-profits-from-big-data%20via%20%40coindesk" target="_blank" rel="noopener noreferrer" class="twitter" title="Share on Twitter"><svg class="svg-icon" viewBox="0 0 24 24"><path fill="#fff" d="M24 4.557c-.883.392-1.832.656-2.828.775 1.017-.609 1.798-1.574 2.165-2.724-.951.564-2.005.974-3.127 1.195-.897-.957-2.178-1.555-3.594-1.555-3.179 0-5.515 2.966-4.797 6.045-4.091-.205-7.719-2.165-10.148-5.144-1.29 2.213-.669 5.108 1.523 6.574-.806-.026-1.566-.247-2.229-.616-.054 2.281 1.581 4.415 3.949 4.89-.693.188-1.452.232-2.224.084.626 1.956 2.444 3.379 4.6 3.419-2.07 1.623-4.678 2.348-7.29 2.04 2.179 1.397 4.768 2.212 7.548 2.212 9.142 0 14.307-7.721 13.995-14.646.962-.695 1.797-1.562 2.457-2.549z"></path></svg></a></h4><div class="card-desc"><span class="card-author"><a title="Articles by Alex McDougall" href="/author/alex-mcdougall">Alex McDougall</a></span><span class="card-date">Dec 28, 2019</span></div></div></section></div></li><li style="margin-right:48px"><div><section class="article-card "><div class="decoration"></div><div class="card-img-block"><a title="Blockchain Projects Are Just Entering the Netscape Phase" href="/blockchain-projects-are-just-entering-the-netscape-phase"><picture><img src="https://static.coindesk.com/wp-content/uploads/2019/12/David20Nage20Brigther-1.png_width1322nameDavid20Nage20Brigther-1-710x458.png" alt="" loading="lazy" class="article-card-img"/></picture></a><a class="button eyebrow-button" href="/tag/year-in-review-2019"><span class="eyebrow-button-text">Year in Review 2019</span><svg class="svg-icon" x="0px" y="0px" viewBox="0 0 18 12" width="18" height="12"><g fill-rule="nonzero"><path d="M16.1 6.5H0v-1h16.1L11.64.846l.72-.692L17.966 6l-5.604 5.846-.722-.692L16.101 6.5z"></path></g></svg></a></div><div class="card-text-block"><h4 class="heading"><a title="Blockchain Projects Are Just Entering the Netscape Phase" href="/blockchain-projects-are-just-entering-the-netscape-phase">Blockchain Projects Are Just Entering the Netscape Phase</a> <a href="https://twitter.com/intent/tweet?text=Blockchain%20Projects%20Are%20Just%20Entering%20the%20Netscape%20Phase%20https%3A%2F%2Fwww.coindesk.com%2Fblockchain-projects-are-just-entering-the-netscape-phase%20via%20%40coindesk" target="_blank" rel="noopener noreferrer" class="twitter" title="Share on Twitter"><svg class="svg-icon" viewBox="0 0 24 24"><path fill="#fff" d="M24 4.557c-.883.392-1.832.656-2.828.775 1.017-.609 1.798-1.574 2.165-2.724-.951.564-2.005.974-3.127 1.195-.897-.957-2.178-1.555-3.594-1.555-3.179 0-5.515 2.966-4.797 6.045-4.091-.205-7.719-2.165-10.148-5.144-1.29 2.213-.669 5.108 1.523 6.574-.806-.026-1.566-.247-2.229-.616-.054 2.281 1.581 4.415 3.949 4.89-.693.188-1.452.232-2.224.084.626 1.956 2.444 3.379 4.6 3.419-2.07 1.623-4.678 2.348-7.29 2.04 2.179 1.397 4.768 2.212 7.548 2.212 9.142 0 14.307-7.721 13.995-14.646.962-.695 1.797-1.562 2.457-2.549z"></path></svg></a></h4><div class="card-desc"><span class="card-author"><a title="Articles by David Nage" href="/author/davidnage">David Nage</a></span><span class="card-date">Dec 28, 2019</span></div></div></section></div></li><li style="margin-right:48px"><div><section class="article-card "><div class="decoration"></div><div class="card-img-block"><a title="Camila Russo and David Hoffman on the 2020 DeFi Outlook" href="/camila-russo-and-david-hoffman-on-the-2020-defi-outlook"><picture><img src="https://static.coindesk.com/wp-content/uploads/2019/12/CamiDavid-long-710x458.jpg" alt="" loading="lazy" class="article-card-img"/></picture></a><a class="button eyebrow-button" href="/tag/podcasts"><span class="eyebrow-button-text">Podcasts</span><svg class="svg-icon" x="0px" y="0px" viewBox="0 0 18 12" width="18" height="12"><g fill-rule="nonzero"><path d="M16.1 6.5H0v-1h16.1L11.64.846l.72-.692L17.966 6l-5.604 5.846-.722-.692L16.101 6.5z"></path></g></svg></a></div><div class="card-text-block"><h4 class="heading"><a title="Camila Russo and David Hoffman on the 2020 DeFi Outlook" href="/camila-russo-and-david-hoffman-on-the-2020-defi-outlook">Camila Russo and David Hoffman on the 2020 DeFi Outlook</a> <a href="https://twitter.com/intent/tweet?text=Camila%20Russo%20and%20David%20Hoffman%20on%20the%202020%20DeFi%20Outlook%20https%3A%2F%2Fwww.coindesk.com%2Fcamila-russo-and-david-hoffman-on-the-2020-defi-outlook%20via%20%40coindesk" target="_blank" rel="noopener noreferrer" class="twitter" title="Share on Twitter"><svg class="svg-icon" viewBox="0 0 24 24"><path fill="#fff" d="M24 4.557c-.883.392-1.832.656-2.828.775 1.017-.609 1.798-1.574 2.165-2.724-.951.564-2.005.974-3.127 1.195-.897-.957-2.178-1.555-3.594-1.555-3.179 0-5.515 2.966-4.797 6.045-4.091-.205-7.719-2.165-10.148-5.144-1.29 2.213-.669 5.108 1.523 6.574-.806-.026-1.566-.247-2.229-.616-.054 2.281 1.581 4.415 3.949 4.89-.693.188-1.452.232-2.224.084.626 1.956 2.444 3.379 4.6 3.419-2.07 1.623-4.678 2.348-7.29 2.04 2.179 1.397 4.768 2.212 7.548 2.212 9.142 0 14.307-7.721 13.995-14.646.962-.695 1.797-1.562 2.457-2.549z"></path></svg></a></h4><div class="card-desc"><span class="card-author"><a title="Articles by Nathaniel Whittemore" href="/author/nwhittemore">Nathaniel Whittemore</a></span><span class="card-date">Dec 27, 2019</span></div></div></section></div></li><li style="margin-right:48px"><div><section class="article-card "><div class="decoration"></div><div class="card-img-block"><a title="Treadway Commission to Issue Blockchain Security Guidance in 2020" href="/treadway-commission-to-issue-blockchain-security-guidance-in-2020"><picture><img src="https://static.coindesk.com/wp-content/uploads/2019/12/accounting-710x458.jpg" alt="&quot;Account Book Ledger&quot; by John Carlin is licensed under CC0 1.0" loading="lazy" class="article-card-img"/></picture></a><a class="button eyebrow-button" href="/tag/cybersecurity"><span class="eyebrow-button-text">Cybersecurity</span><svg class="svg-icon" x="0px" y="0px" viewBox="0 0 18 12" width="18" height="12"><g fill-rule="nonzero"><path d="M16.1 6.5H0v-1h16.1L11.64.846l.72-.692L17.966 6l-5.604 5.846-.722-.692L16.101 6.5z"></path></g></svg></a></div><div class="card-text-block"><h4 class="heading"><a title="Treadway Commission to Issue Blockchain Security Guidance in 2020" href="/treadway-commission-to-issue-blockchain-security-guidance-in-2020">Treadway Commission to Issue Blockchain Security Guidance in 2020</a> <a href="https://twitter.com/intent/tweet?text=Treadway%20Commission%20to%20Issue%20Blockchain%20Security%20Guidance%20in%202020%20https%3A%2F%2Fwww.coindesk.com%2Ftreadway-commission-to-issue-blockchain-security-guidance-in-2020%20via%20%40coindesk" target="_blank" rel="noopener noreferrer" class="twitter" title="Share on Twitter"><svg class="svg-icon" viewBox="0 0 24 24"><path fill="#fff" d="M24 4.557c-.883.392-1.832.656-2.828.775 1.017-.609 1.798-1.574 2.165-2.724-.951.564-2.005.974-3.127 1.195-.897-.957-2.178-1.555-3.594-1.555-3.179 0-5.515 2.966-4.797 6.045-4.091-.205-7.719-2.165-10.148-5.144-1.29 2.213-.669 5.108 1.523 6.574-.806-.026-1.566-.247-2.229-.616-.054 2.281 1.581 4.415 3.949 4.89-.693.188-1.452.232-2.224.084.626 1.956 2.444 3.379 4.6 3.419-2.07 1.623-4.678 2.348-7.29 2.04 2.179 1.397 4.768 2.212 7.548 2.212 9.142 0 14.307-7.721 13.995-14.646.962-.695 1.797-1.562 2.457-2.549z"></path></svg></a></h4><div class="card-desc"><span class="card-author"><a title="Articles by Daniel Kuhn" href="/author/danielcoindesk-com">Daniel Kuhn</a></span><span class="card-date">Dec 27, 2019</span></div></div></section></div></li><li style="margin-right:48px"><div><section class="article-card "><div class="decoration"></div><div class="card-img-block"><a title="Sovereign Powers Could Be Key to Mass Crypto Adoption" href="/sovereign-powers-could-be-key-to-mass-crypto-adoption"><picture><img src="https://static.coindesk.com/wp-content/uploads/2019/12/ryan-zurrer-web3-foundation-710x458.jpg" alt="" loading="lazy" class="article-card-img"/></picture></a><a class="button eyebrow-button" href="/tag/year-in-review-2019"><span class="eyebrow-button-text">Year in Review 2019</span><svg class="svg-icon" x="0px" y="0px" viewBox="0 0 18 12" width="18" height="12"><g fill-rule="nonzero"><path d="M16.1 6.5H0v-1h16.1L11.64.846l.72-.692L17.966 6l-5.604 5.846-.722-.692L16.101 6.5z"></path></g></svg></a></div><div class="card-text-block"><h4 class="heading"><a title="Sovereign Powers Could Be Key to Mass Crypto Adoption" href="/sovereign-powers-could-be-key-to-mass-crypto-adoption">Sovereign Powers Could Be Key to Mass Crypto Adoption</a> <a href="https://twitter.com/intent/tweet?text=Sovereign%20Powers%20Could%20Be%20Key%20to%20Mass%20Crypto%20Adoption%20https%3A%2F%2Fwww.coindesk.com%2Fsovereign-powers-could-be-key-to-mass-crypto-adoption%20via%20%40coindesk" target="_blank" rel="noopener noreferrer" class="twitter" title="Share on Twitter"><svg class="svg-icon" viewBox="0 0 24 24"><path fill="#fff" d="M24 4.557c-.883.392-1.832.656-2.828.775 1.017-.609 1.798-1.574 2.165-2.724-.951.564-2.005.974-3.127 1.195-.897-.957-2.178-1.555-3.594-1.555-3.179 0-5.515 2.966-4.797 6.045-4.091-.205-7.719-2.165-10.148-5.144-1.29 2.213-.669 5.108 1.523 6.574-.806-.026-1.566-.247-2.229-.616-.054 2.281 1.581 4.415 3.949 4.89-.693.188-1.452.232-2.224.084.626 1.956 2.444 3.379 4.6 3.419-2.07 1.623-4.678 2.348-7.29 2.04 2.179 1.397 4.768 2.212 7.548 2.212 9.142 0 14.307-7.721 13.995-14.646.962-.695 1.797-1.562 2.457-2.549z"></path></svg></a></h4><div class="card-desc"><span class="card-author"><a title="Articles by Ryan Zurrer" href="/author/ryanzurrer">Ryan Zurrer</a></span><span class="card-date">Dec 27, 2019</span></div></div></section></div></li></ul><div class="recirculation-desktop-controls"><div class="scroll-bar"><div class="scroll-track"><div class="scroll-thumb" style="width:69.83240223463687%;left:30.16759776536313%"></div></div></div><div class="recirculation-desktop-bottom"><div class="recirculation-desktop-arrows"><button aria-label="Previous"><svg class="svg-icon" x="0px" y="0px" viewBox="0 0 12 12"><path d="M1.3,6.3l4.6,5.2l-0.4,0.4l-5-5.5l0,0l0,0L0.3,6l5.2-5.8l0.4,0.4L1.3,5.8h9.8v0.6L1.3,6.3L1.3,6.3z"></path></svg></button><button aria-label="Next"><svg class="svg-icon" x="0px" y="0px" viewBox="0 0 12 12"><path d="M10.1,5.7L5.5,0.5l0.4-0.3l5,5.5l0,0l0,0L11.1,6l-5.2,5.8l-0.4-0.4l4.6-5.1H0.2V5.7H10.1L10.1,5.7z"></path></svg></button></div></div></div></div></div></div></div></div></section></main><footer class="site-footer"><div class="site-footer-wrapper"><div class="footer-top "><nav class="footer-nav"><a class="coindesk-logo" href="/"><img src="https://static.coindesk.com/images/logo-5ce6d3185603319740c3c34bbf2ec628.svg" alt="CoinDesk Bitcoin News"/></a><div><div class="footer-row"><a title="About" href="/about">About</a></div><div class="footer-row"><a title="Blog" href="/blog">Blog</a></div><div class="footer-row"><a title="Editorial Policy" href="/editorial-policy">Editorial Policy</a></div><div class="footer-row"><a title="Press" href="/press">Press</a></div><div class="footer-row"><a href="https://boards.greenhouse.io/coindesk" target="_blank" rel="noopener noreferrer" title="Jobs">Jobs</a></div><div class="footer-row"><a title="Events" href="/events">Events</a></div></div></nav></div><div class="newsletter-wrapper"><div class=""><h4 class="heading">Follow us</h4><div class="social-profiles"><span><a href="https://twitter.com/coindesk" target="_blank" rel="noopener noreferrer" class="twitter" title="Follow us on Facebook"><svg class="svg-icon" viewBox="0 0 24 24"><path fill="#fff" d="M24 4.557c-.883.392-1.832.656-2.828.775 1.017-.609 1.798-1.574 2.165-2.724-.951.564-2.005.974-3.127 1.195-.897-.957-2.178-1.555-3.594-1.555-3.179 0-5.515 2.966-4.797 6.045-4.091-.205-7.719-2.165-10.148-5.144-1.29 2.213-.669 5.108 1.523 6.574-.806-.026-1.566-.247-2.229-.616-.054 2.281 1.581 4.415 3.949 4.89-.693.188-1.452.232-2.224.084.626 1.956 2.444 3.379 4.6 3.419-2.07 1.623-4.678 2.348-7.29 2.04 2.179 1.397 4.768 2.212 7.548 2.212 9.142 0 14.307-7.721 13.995-14.646.962-.695 1.797-1.562 2.457-2.549z"></path></svg></a></span><span><a href="https://facebook.com/coindesk" target="_blank" rel="noopener noreferrer" class="facebook" title="Follow us on Facebook"><svg class="svg-icon" width="24" height="24" viewBox="0 0 24 24"><path d="M9 8h-3v4h3v12h5v-12h3.642l.358-4h-4v-1.667c0-.955.192-1.333 1.115-1.333h2.885v-5h-3.808c-3.596 0-5.192 1.583-5.192 4.615v3.385z"></path></svg></a></span><span><a href="https://linkedin.com/company/coindesk" target="_blank" rel="noopener noreferrer" class="linkedin" title="Follow us on LinkedIn"><svg class="svg-icon" viewBox="0 0 24 24"><path d="M4.98 3.5c0 1.381-1.11 2.5-2.48 2.5s-2.48-1.119-2.48-2.5c0-1.38 1.11-2.5 2.48-2.5s2.48 1.12 2.48 2.5zm.02 4.5h-5v16h5v-16zm7.982 0h-4.968v16h4.969v-8.399c0-4.67 6.029-5.052 6.029 0v8.399h4.988v-10.131c0-7.88-8.922-7.593-11.018-3.714v-2.155z"></path></svg></a></span></div><section class="newsletter-card "><div class="desc-content"><h2 class="heading">Get the Latest from CoinDesk</h2><p>Sign up for our newsletter</p><div class="checkboxes"><div class="coindesk-checkbox"><div class="pretty p-svg p-smooth"><input type="checkbox" id="checkbox-bites-96706" checked="" name="bites"/><div class="state"><svg class="svg-icon svg svg-icon" width="20" height="20" x="0px" y="0px" viewBox="0 0 20 20"><path d="M5.25 9.486L14.543 0 16 1.428 5.307 12.343 0 7.34l1.4-1.484z"></path></svg><label for="checkbox-bites-96706"><span>Daily</span></label></div></div></div><div class="coindesk-checkbox"><div class="pretty p-svg p-smooth"><input type="checkbox" id="checkbox-markets-96706" checked="" name="markets"/><div class="state"><svg class="svg-icon svg svg-icon" width="20" height="20" x="0px" y="0px" viewBox="0 0 20 20"><path d="M5.25 9.486L14.543 0 16 1.428 5.307 12.343 0 7.34l1.4-1.484z"></path></svg><label for="checkbox-markets-96706"><span>Markets</span></label></div></div></div><div class="coindesk-checkbox"><div class="pretty p-svg p-smooth"><input type="checkbox" id="checkbox-institutional-96706" checked="" name="institutional"/><div class="state"><svg class="svg-icon svg svg-icon" width="20" height="20" x="0px" y="0px" viewBox="0 0 20 20"><path d="M5.25 9.486L14.543 0 16 1.428 5.307 12.343 0 7.34l1.4-1.484z"></path></svg><label for="checkbox-institutional-96706"><span>Institutional</span></label></div></div></div></div><p class="gdpr-copy">By signing up, you will receive emails about CoinDesk products and you agree to our<!-- --> <a href="/terms" target="_blank">terms &amp; conditions</a> <!-- -->and<!-- --> <a href="/privacy" target="_blank">privacy policy</a></p></div><div class="singup-input-controls input-content"><input type="email" placeholder="Enter your mail" value=""/><div class="buttons"><button disabled="" class="button primary-button primary-button-default disabled">Sign Up</button></div></div><div class="error-content ">Please enter a valid email address</div></section></div></div><div class="footer-bottom"><nav class="footer-nav "><div role="navigation" aria-label="Footer navigation"><div class="footer-row"><a href="/terms">Terms &amp; Conditions</a></div><div class="footer-row"><a href="/privacy">Privacy Policy</a></div><div class="footer-row"><a href="/newsletter">Newsletters</a></div><div class="footer-row">© 2019 CoinDesk</div><div class="footer-row"><div class="dropdown-select dropdown-eyebrow-false dropdown-theme-lightning-yellow "><div class="dropdown-header"><div class="dropdown-header-title">English<!-- --> <svg class="chevron-arrow" width="22" height="11" viewBox="0 0 22 11"><path d="M21.7,1L11,11L0.3,1"></path></svg></div></div></div></div></div><p class="footer-copy">The leader in blockchain news, CoinDesk is a media outlet that strives for the highest journalistic standards and abides by a<!-- --> <a href="/editorial-policy">strict set of editorial policies</a>. CoinDesk is an independent operating subsidiary of<!-- --> <a href="https://dcg.co" target="_blank" rel="noopener noreferrer">Digital Currency Group</a>, which invests in cryptocurrencies and blockchain startups.</p></nav></div></div></footer></div><script id="__NEXT_DATA__" type="application/json" crossorigin="anonymous">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</script><script crossorigin="anonymous" nomodule="" src="https://static.coindesk.com/runtime/polyfills-2bfd4dc63690a988e8e6.js"></script><script async="" data-next-page="/[slug]" src="https://static.coindesk.com/2.7.0/pages/%5Bslug%5D.js" crossorigin="anonymous"></script><script async="" data-next-page="/_app" src="https://static.coindesk.com/2.7.0/pages/_app.js" crossorigin="anonymous"></script><script src="https://static.coindesk.com/runtime/webpack-8fb5bf10fdd6e1b93d46.js" async="" crossorigin="anonymous"></script><script src="https://static.coindesk.com/chunks/commons.9bc87ee77954726641bc.js" async="" crossorigin="anonymous"></script><script src="https://static.coindesk.com/chunks/styles.093f8a110b0749276289.js" async="" crossorigin="anonymous"></script><script src="https://static.coindesk.com/runtime/main-dbdf3d4a43eea9f43f09.js" async="" crossorigin="anonymous"></script></body></html>